US1 Edge Services Maintenance on September 26th 2021 (extended)
Incident Report for Storj DCS
Resolved
This incident has been resolved.
Posted Sep 26, 2021 - 10:20 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 26, 2021 - 10:20 UTC
Investigating
We are currently investigating this issue.
Posted Sep 26, 2021 - 10:02 UTC
This incident affected: US1 (US1 - Linksharing).