EU1 access keys becoming non-functional

Incident Report for Storj DCS

Postmortem

On September 13th, 2025, we experienced an issue that caused access keys to stop working for some customers in the EU1 region. This problem was isolated to a small subset of our infrastructure. We identified the root cause as a database configuration mismatch that occurred during a software update performed the previous day at approximately 21:12 UTC. Our team quickly redirected traffic away from the affected server to minimize service interruption. After implementing the necessary configuration changes, we were able to restore full functionality.

The service has fully recovered, and we're taking steps to prevent similar issues in the future. We apologize for any inconvenience this may have caused.

Posted Sep 19, 2025 - 15:30 UTC

Resolved

This incident has been resolved.
Posted Sep 13, 2025 - 08:22 UTC

Update

We are continuing to investigate this issue.
Posted Sep 13, 2025 - 08:14 UTC

Investigating

We have been alerted to an issue causing access keys in the EU1 region to stop working.
Posted Sep 13, 2025 - 05:52 UTC
This incident affected: EU1 (EU1 - Linksharing, EU1 - Gateway).