Elevated error rates for US1 Select

Incident Report for Storj DCS

Resolved

The previously identified issue affecting performance has been resolved.
Posted Mar 06, 2026 - 12:31 UTC

Monitoring

We have applied a fix for the previously mentioned performance impact and are continuing to monitor the system.
Posted Mar 06, 2026 - 10:48 UTC

Investigating

We are currently investigating this issue.
Posted Mar 06, 2026 - 10:10 UTC
This incident affected: US1 (US1 - Select).