Issue with edge services in Europe having intermittent connection timeouts and slow response times
Incident Report for Storj DCS
Resolved
The issue with edge services in Europe having intermittent connection timeouts and slow response times has been resolved for all affected users.

We thank you for your patience while we worked on resolving the issue.
Posted Jul 18, 2024 - 23:55 UTC
Investigating
We are experiencing an issue with European edge services capacity having intermittent connection timeouts and slow response times.

Our engineering team is actively investigating.

We apologize to all who are affected by the disruption.
Posted Jul 18, 2024 - 17:45 UTC
This incident affected: EU1 (EU1 - Linksharing, EU1 - Gateway).