www.storj.io returning 500 errors

Incident Report for Storj DCS

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 19:34 UTC

Investigating

The main storj landing page is returning 500 errors.

All Storj services remain unaffected. Use https://www.storj.io/login to login to the web console and use your accounts until this is resolved.
Posted Sep 18, 2025 - 18:41 UTC